The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 802 - File: showthread.php PHP 7.2.30 (Linux)
File Line Function
/showthread.php 802 errorHandler->error



Hello There, Guest!  LoginRegister
Welcome to the former forums for DidYouKnowGaming?! In March of 2013, VGFacts was launched and this community was merged into the new forums there. These forums were originally taken offline at that time but I brought them back as an archive while transferring sites to the new server. Registrations and all interaction (posting, editing, moderation, etc.) are disabled but everything can still be read. If you're interested in joining the community, head on over to https://www.vgfacts.com/forums/ and join there but I've always thought it was important to preserve a site's roots so these forums will forever be available in this read-only state. Enjoy!
-Petie

Post Reply 
 
Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SERIOUSLY attempts - Ocarina of Time
Author Message
SERIOUSLY THOUGH Offline
Solo Diver
******

Posts: 2,154
Joined: Jul 2012
Reputation: 35
Thanks: 35
Given 689 thank(s) in 484 post(s)
Post: #1
SERIOUSLY attempts - Ocarina of Time
So here’s the thing. It turns out I’ve never played what is often referred to as one of the greatest games of all time – “Ocarina of Time.” Mainly because I’ve never owned an N64, but also because OoT isn’t really something you play when a friend comes over.

So further to A Zombie Riot’s request, I’ve decided to share my experience with you all.


- Episode 1 -

I’ve got to say that I’m not happy. I boot up the game, then the little intro movie starts. I watch Link faff around on his horse for about five minutes galloping through a field, stopping by a babbling brook for no apparent reason before taking off again. Then he arrives at some sort of castle and the sliding wooden door opens. Who is it going to be? Maybe a secondary character? Perhaps some random villager, coming to greet me? WRONG. I’m met with the biggest goddamn spoiler of any pre-game intro A.K.A. bloody Ganondorf, whisking Zelda away on horseback. Thanks.
To be fair, this is a Zelda game so chances are she’s going to get kidnapped by Gammondorf at some point. But still, it’s like starting a Star Wars movie with a complete run-down of the Skywalker family tree. So, slightly annoyed, I create a new character and boom I’m thrown into the world of LoZ.

I think that the makers of OoT took “How to make a character seem like a wet flannel 101.” I start the game thinking “hell yeah, I’m Link, I’m here to crush evil with my sword and shield, and various other things I find along the way". Nope. I’m greeted with “Your character sucks so much, he hasn’t been deemed worthy of having a fairy. Sorry,” followed by a nauseating first-person fly around by the thing I expect to become that “hey listen” fairy I’ve heard so much about. If Link’s about to get a fairy, I sure bloody well hope it’s not this one. We’re treated to the worst display of aerial manoeuvrability ever, with our character running into objects such as a mesh gate, when going in a straight line would have been just fine.

And of course, the damn thing comes into Link’s house (breaking and entering may I add), and tries to wake him up. Link is obviously not ready to give up any of the 20 fucks he was attributed at birth, and keeps sleeping. Unfortunately for him, fairy-thing doesn’t seem to understand and pesters him until he finally snaps out of his reverie.

What we then get is a brief monologue along the lines of “you must go see the Arbre Mojo” (bear in mind I’m playing in French, so names and such will not be given in English). And Link, seemingly too imbecilic to ask 1. Who are you, 2. Why did you break into my house, 3. I’m going to need a bit more information before going to see a tree called “Mojo.”, just thinks “seems legit” and runs outside, only to be hailed by some condescending blonde elf-person who goes “Ohhh you got a fairy, well done, now go do stuff.” SUBTEXT – “Oh wow, you’re no longer a total outcast; now go away, I don’t want to see your face.” This last point further proved by the fact that she just stands there, smiling at you until you do actually go away.


[Image: NngZp.jpg]
That smile is one of both derision, and pity


At this point, I hear my first real “HEY.” Right, little fairy-thing, what do you want? “GO SEE THE ARBRE MOJO.” No REALLY!? Apparently Link also suffers from short-term memory loss. This is further proved by the fact that every time I speak to someone, they repeat the same thing, as if they expected me to forget “I can’t lift these rocks.” Lift your own goddamn rocks…


[Image: 7ZELx.jpg]
I don't know who this "Mido" is, but you, Sir, are his bitch


After running around Kakariko village for a bit, I gleaned that I need to find a sword and shield. I learnt this from some self-righteous prick who seems to think that Link can’t fight for himself. This dude just side-shuffles in a very precise semi-circle, totally ignoring the fact that I’ve been summoned by a sentient tree called Mojo in order to save the world.

So I run around, until I meet condescending elf-person number 6 inside the general store. At this point, I’ve realised that Link is not only an apparent simpleton to whom the most idiotic fairy has been allocated, but incredibly poor. As in ‘can’t even buy a wooden shield’ poor. A wooden shield. In a forest. A forest made of trees. Surely he can just cut down a tree and hew it roughly into the shape of a shield? No? Fine. So I talk to condescending elf-thing number 6, who tells me something that has nothing to do with anything even remotely useful before giving up and going back out in search for a sword, ignoring bitch elf-person number 1 with his rocks. After much searching, I crawl into a tunnel, and into physics Wonderland. Seriously though, who thought it would be a good idea to have a boulder charging around in a village populated by children...


[Image: GItEd.jpg]
0.2 seconds before OoT's sequel - Legend of Zelda, Link's Awakening in an ICU


So I have my sword, and my first dndndndndundundundundundundundunduunduunduunduun DUN DUN DUN DUUUUUUUUN. Yeah, you took a sword from an unlocked chest. Link obviously has low expectations of himself. He even turns to the camera as if to say “Look daddy, I found a sword. Are you proud of me?” No Link. I’ll be proud of you when you learn to speak. You’re currently going all Freeman on the world. That’s why you have no friends.

I leave the tunnel, and am back into Kakariko Village – which is a strange name, because in French, cockerels go “cocorico”, or “Kokoriko” if you will. So basically I live in Cock Village. Excellent. I run around with my new sword hacking at grass, feeling like a badass, and I see a sign. I read it and it says “please do not slash the signs.” Now there’s your problem. The idea hadn’t even come to my mind until you mentioned it. Cue 5 minute sign genocide. A genocide that isn’t helped by the fact that I keep finding blue crystal-things behind them. Way to positively reinforce Link’s anti-social aggressive tendencies. That’ll get him some more friends.


[Image: mKmNG.jpg]
Fuck the system


So I finally have my 40 crystal-things so I go back to the d-bag who won’t give the shield I need to save the world for free. DUN DUN DUN DUUUUUUUUUN!! I have a shiiieeeeld!! No Link. I still don’t respect you.


[Image: VHdD4.jpg]
Creepy Link, condescending elf-person number 6, and d-bag


And here I am; sword and shield equipped – ready to go meet the dubiously named “Mojo.” But that’s for another day – I think I’ve already typed enough for now.

Next episode - Why Kakariko Village is a logistic, societal, and infrastructural hell-hole.

- SERIOUSLY
(This post was last modified: 12-02-2012 11:13 PM by SERIOUSLY THOUGH.)
12-02-2012 11:46 AM
Find all posts by this user Quote this message in a reply
 Thanks given by: Nuudoru , Zaliphone , Xannidel , BumblebeeCody , A Zombie Riot , Liraxus , Amaterasu
Post Reply 


Messages In This Thread
SERIOUSLY attempts - Ocarina of Time - SERIOUSLY THOUGH - 12-02-2012 11:46 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)